Rabu, 11 September 2019

Install dan Konfigurasi Samba Server di ArchLinux

  Tidak ada komentar
18.13

Latar Belakang
Suatu saat, salah satu teman saya ingin meminta subuah file iso yang ukuranya lumayan besar, namun beliau tidak membawa storage berupa flasdisk/semacamnya. Alhasil saya kepikiran untuk memanfaatkan fitur sharing menggunakan jaringan komputer.  Namun, ternyata untuk sistem operasi ArchLinux, fitur tersebut belum include ke dalam sistemnya dasar, oleh karena itu saya mencoba instal software samba yang bersifat opensource, proses dokumentasi penginstalan seperti berikut.


Instalasi Samba

$ yay -S samba


Konfigurasi Samba
semua konfigurasi samba terdapat di dalam file /etc/samba/smb.conf, namun dikarenakan paket samba tidak disertakan file smb.conf didalamnya, maka buatlah file /etc/samba/smb.conf dan mengacu pada Samba Git Repository 

$ sudo nano /etc/samba/smb.conf

copy file Samba Git Repository ke dalam smb.conf, modifikasi beberapa kofigurasi

modifikasi log file = /usr/local/samba/var/log.%m menjadi
log file = /var/log/samba/&m.log


Batasi directory home supaya tidak dibagikan, tambahkan ; di depan bagian [homes]

tambahkan konfigurasi baru yang digunakan untuk file sharing, disini saya membuat [shared-mixroba], path disini nantinya adalah letak direktori yang digunakan untuk sharing
[share-mixroba]
  comment = MixRoBa Share Files
  path = /home/fahrul/shared
  valid users = fahrul
  public = no
  writable = yes
  printable = no
  create mask = 0765


User Management
Samba memerlukan linux user yang nantinya digunakan untuk mengakses samba servernya. Kita bisa menggunakan user yang sudah ada, bisa juga kita menggunakan user tersendiri untuk samba usernyanya, disini saya menggunakan user yang sudah ada dengan nama fahrul

tambahkan password user tersebut yang digunakan khusus untuk mengakses samba servernya
$ sudo smbpasswd -a fahrul


tambahkan group sambashare
$ sudo groupadd -r sambashare



Folder Management
Buatlah direktori baru yang mengacu path didalam file konfigurasi smb.conf

$ mkdir /home/fahrul/shared


rubah kepemilikan folder tersebut dari :root: menjadi :sambashare: dan rubah permisssion direktori shared agar sambashare group dapat read,write dan execute file

Fahrul Ahmad Fauzi
Pendidikan Teknik Informatika
Universitas Negeri Yogyakarta





Read More

Rabu, 04 September 2019

Resensi Buku "Raspberry Pi, Mikrokontroller Mungil yang Serba Bisa"

  Tidak ada komentar
08.27




Judul Buku : “RasberryPi” Mikrokontroller Mungil yang Serba Bisa
Pengarang Buku : Edi Rakhman, Faisal Candrasyah, Fajar D.Sutera
Penerbit Buku : Penerbit Andi Yogyakarta (CV ANDI OFFSET)
Tahun Terbit : 2014
Tebal Buku : 152 halaman

Sinopsis buku RasberyPi, Mikrokontroller Mungil yang Serba Bisa

Buku ini sangat cocok dibaca bagi kalangan pengguna Raspberry Pi pemula, terutama bagi yang tengah mengerjakan proyek akhir atau tugas akhir yang memerlukan kontroller digital yang mampu berfungsi sebagai komputer desktop atau mampu menyimpan data yang cukup besar sekelas mikrokontroller

Buku ini terbagi atas 6 bab. Dimulai dengan pemaparan masing-masing komponenya hingga asal-usul atau sejarah singkat Raspberry Pi berikut evolusinya hingga buku ini diterbitkan. Bab 2 cukup krusial bagi Anda, karena pada bab tersebut disajikan bagaimana membangun sistem operasi Raspbian, yang dalam hal ini menggunakan Linux Debian (bawaan Raspberry Pi). Di bab ini juga dilengkapi dengan cara-cara mengakses Raspberry Pi, mulai dari langsung pada fisik Raspberry. Pada kondisi ini, Raspberry berfungsi sebagai CPU komputer mungil. Cara lainya adalah dengan menghubungkan melalui terminal LAN(terminal LAN, RJ-45) yang dihubungkan secara peer to peer atau melalui switch. Untuk mengaksesnya, dapat digunakan program SSH(putty) atau melalui program remote desktop seperti VNC. Selanjutnya, Bab 3 menjelaskan tentang Raspberry, mulai dari kelengkapan fisiknya hingga sistem operasi yang dapat dijalankan di Raspberry Pi. Linux secara umum dijelaskan pada bab ini untuk membantu anda belajar linux secara instan. Bab 4 khusus menjelaskan tentang GPIO, modul terpenting Raspbery Pi jika digunakan sebagai kontroller/pengendali digital. Di bab 5 diperkenalkan bahasa pemrograman Python, yang merupakan bahasa natural untuk mengeksplorasi Raspberry Pi sebagai kontroller. Bab 6 mengakhiri buku ini dengan menyajikan beberapa proyek fundamental agar pembaca mendapat gambaran umum bagaimana Raspberry Pi dapat diaplikasikan sebagai kontroller. Untuk Bab 5 dan 6 disediakan skrip agar pembaca dapat berlatih sesuai petunjuk buku ini.

Kelebihan buku
Buku ini menjelaskan dengan detail mengenai topik yang akan di bahas oleh buku. Misalnya mengenai aspek instalisasi raspberry pi penulis menjelaskan secara runtut mulai dari persiapan peralatan hingga siap digunakan untuk banyak keperluan bahkan buku ini juga dilengkapi dengan gambar untuk memudahkan pembacanya

Kekurangan buku
memang buku ini dilengkapi dengan adanya gambar untuk memudahkan pembacanya, namun sangat disayangkan, beberapa gambar di dalam buku ini berukuran kecil dikarenakan posisi gambar yang disejajarkan sehingga membuat para pembaca merasa kurang nyaman.


Untuk mendapatan buku ini anda dapat mencarinta diperpustakaan ataupun dapat juga membeli di toko buku offline maupun toko buku online, dalam pembuatan artikel ini, buku ini saya pinjam di perpustakaan UNY yang terletak di sebelah barat rektorat UNY

Ketersediaan buku ini di perpustakaan UNY dapat dilihat disini


Read More

Senin, 26 Agustus 2019

Penerapan Routing BGP di Cisco

  Tidak ada komentar
20.15


Dalam tutorial kali ini saya akan menjelaskan salah satu penerapan routing protocol BGP di cisco, dengan menggunkan tools cisco packet tracer

BGP merupakan salah satu jenis routing protokol yang digunakan untuk koneksi antar Autonomous System (AS), dan salah satu jenis routing protokol yang banyak digunakan di ISP maupun perbankan. BGP termasuk dalam kategori routing protokol jenis Exterior Gateway Protokol (EGP).
(https://santekno.blogspot.co.id/)

Dalam studi kasus ini, saya akan menerapkan gabungan antara routing protocol EGP dengan IGP, dan protocol IGP yang akan saya terapkan yaitu OSPF dan EIGRP dengan topologi seperti berikut

Langkah-langkah:

1. Tambahkan IP di Setiap Interface
R1 (kiri bawah)Router>enable
Router#conf t
Router(config)#int gi0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int gi0/1
Router(config-if)#ip add 11.11.11.1 255.255.255.252
Router(config-if)#no shut
Router(config-router)#exit

R1 (kiri atas)
Router>enable
Router#conf t
Router(config)#int gi0/0
Router(config-if)#ip add 11.11.11.2 255.255.255.252
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int gi0/1
Router(config-if)#ip add 10.10.10.1 255.255.255.252
Router(config-if)#no shut
Router(config-router)#exit

R3 (kanan atas)
Router>enable
Router#conf t
Router(config)#int gi0/0
Router(config-if)#ip add 10.10.10.2 255.255.255.252
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int gi0/1
Router(config-if)#ip add 12.12.12.1 255.255.255.252
Router(config-if)#no shut
Router(config-router)#exit

R3 (kanan bawah)
Router>enable
Router#conf t
Router(config)#int gi0/0
Router(config-if)#ip add 12.12.12.2 255.255.255.252
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int gi0/1
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shut
Router(config-router)#exit

2. Tambahkan Routing OSPF maupun EIGRP
EIGRP
R1 (kiri bawah)
Router(config)#router eigrp 1
Router(config-router)#network 192.168.1.0
Router(config-router)#network 11.11.11.0
Router(config-router)#exit


R1 (kiri atas)
Router(config)#router eigrp 2
Router(config-router)#network 11.11.11.0
Router(config-router)#exit

OSPF
R3 (kanan atas)
Router(config)#router ospf 1
Router(config-router)#network 12.12.12.0 0.0.0.3 area 1
Router(config-router)#exit

R4 (kanan bawah)
Router(config)#router ospf 1
Router(config-router)#network 192.168.2.0 0.0.0.255 area 1
Router(config-router)#network 12.12.12.0 0.0.0.3 area 1
Router(config-router)#exit

3. Tambahkan Routing BGP
R2 (kiri atas)
Router(config)#router bgp 100
Router(config-router)#neighbor 10.10.10.2 remote-as 200
Router(config-router)#network 10.10.10.0
Router(config-router)#exit

R3 (kanan atas)

Router(config)#router bgp 200

Router(config-router)#neighbor 10.10.10.1 remote-as 100

Router(config-router)#network 10.10.10.0
Router(config-router)#exit

4. Redistribute antar protocol Routing
R2 (kiri atas)
Router(config)#router bgp 100
Router(config-router)#redistribute eigrp 2
Router(config-router)#exit
Router(config)#router eigrp 2
Router(config-router)#redistribute bgp 100
Router(config-router)#exit

R3 (kanan atas)

Router(config)#router bgp 200
Router(config-router)#redistribute ospf 1
Router(config-router)#exit
Router(config)#router ospf 1
Router(config-router)#redistribute bgp 200
Router(config-router)#exit

5. Pengujian
PC A (kiri)

C:\>ping 192.168.2.2

Pinging 192.168.2.2 with 32 bytes of data:

Reply from 192.168.2.2: bytes=32 time=1ms TTL=125
Reply from 192.168.2.2: bytes=32 time<1ms TTL=125
Reply from 192.168.2.2: bytes=32 time<1ms TTL=125
Reply from 192.168.2.2: bytes=32 time<1ms TTL=125

Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

PC A (kiri)

C:\>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:


Reply from 192.168.1.2: bytes=32 time=1ms TTL=125
Reply from 192.168.1.2: bytes=32 time<1ms TTL=125
Reply from 192.168.1.2: bytes=32 time<1ms TTL=125
Reply from 192.168.1.2: bytes=32 time<1ms TTL=125

Ping statistics for 192.168.1.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

Fahrul Ahmad Fauzi
Pendidikan Teknik Informatika
Universitas Negeri Yogyakarta

Read More